Service degradation - A subset of customers can potentially experience issues while changing space ownership
Incident Report for Templafy
Postmortem

On July 25, 2024, at 10:31 AM CET, an incident was initiated due to a problem where admins were having problems using the space administration functionality. This issue was specifically related to the assignment of space owner access flow, which could potentially remove all space owners if a user attempted to remove a subset of the owners. The engineering team initiated an investigation upon the incident creation and identified that the issue was caused by a newly created UI component. After isolating the problem the team then moved into the mitigation phase and worked diligently to integrate a solution across all impacted subsystems. At 12:56 CET they managed to deploy the fix to all the production environments. The issue was confirmed to be fixed and management operations for spaces was restored.
We apologize for the disruption and remain committed to ensuring the reliability and stability of our services.

Posted Jul 26, 2024 - 14:59 CEST

Resolved
The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Jul 25, 2024 - 15:36 CEST
Monitoring
The incident has been successfully mitigated, and our team is actively monitoring the situation to ensure ongoing stability and performance. We are observing the systems to prevent any further disruptions.
Posted Jul 25, 2024 - 12:56 CEST
Identified
We have identified an issue that affects a subset of customers and are working towards a resolution.
The issue occurs when admins attempt to change space ownership. The memembership change could potentially have unexpected results.
Further updates will be posted here soon.
Posted Jul 25, 2024 - 10:31 CEST
This incident affected: Templafy Hive (User Management).