Outlook Web Add-ins not functioning correctly in Outlook Desktop
Incident Report for Templafy
Postmortem

On October 30th, 2023, users of the Templafy Email Signature Outlook Web Add-in from the Prod0 West Europe region were not able to use the product on Outlook Desktop for Windows, email signatures were not being inserted automatically and manual insertion took a long time. The issue propagated on October 31st to all regions. Because an Outlook restart was needed to experience the problem, the first reports of it were created with a one day delay.

After running investigations, we identified the problem on an internal library update that introduced two unsupported features in the Outlook Desktop environment, causing the Web Add-in to not load. Upon detecting the issue, our engineers immediately downgraded the internal library, an action taken to rectify the situation. By 13:15 CET, November 1st, the Web Add-in's functionality was fully restored in all regions.

Posted Nov 02, 2023 - 12:59 CET

Resolved
The incident has been resolved by downgrading our UI Library.
Root cause analysis is under way and it will be provided in the upcoming days.
We apologize for the impact to affected customers.
Posted Nov 01, 2023 - 13:17 CET
Update
Upon further investigation we have identified an issue with recent update to our UI Library. We are testing a downgrade of the solution
Posted Nov 01, 2023 - 11:30 CET
Update
We have created an issue on Microsoft Office JS GitHub page and we are waiting for them to acknowledge the issue
Posted Oct 31, 2023 - 11:01 CET
Identified
We have identified the following issues with Outlook Web Add-ins in Outlook Desktop for Windows :

Signatures: Outlook Web Add-ins are failing to insert signatures automatically in outgoing emails.
Task Panes: Task panes are experiencing slow loading times when accessing the Content Library and Email Signatures features.
Actions Taken:
The issue has been reported to the Microsoft Office JS team for further investigation and resolution.
Posted Oct 31, 2023 - 10:12 CET
This incident affected: Templafy Hive (Library & Dynamics, Email Signature).