Service degradation - Some users are receiving errors during document creation
Incident Report for Templafy
Postmortem

On April 22, 2024, at 10:46 AM CET, an issue was reported affecting all users across every cluster, where the dialog for creating or updating documents, containing TextElement or SlideCollection insertions, would not advance beyond the loading screen on subsequent attempts. Initial investigations quickly linked the problem to a recent update in the UserManagement Microfrontend, specifically a defect introduced in the UserProfile component. This issue was rectified by reverting the changes, with normal functionality restored by 2:05 PM CET on the same day.

In response to this incident, we have implemented more rigorous testing procedures for frontend components and expanded end-to-end testing to better simulate user interactions. We've also revised the integration and usage of the UserProfile component to prevent recurrence and introduced new tests that run asynchronously to detect issues early without delaying other processes.
We apologize for the inconvenience caused and are committed to continuous improvements to ensure the reliability of our services.

Posted Apr 25, 2024 - 13:50 CEST

Resolved
The Engineering Team has finished implementing the solution and it has been deployed into all regions.
The incident has now been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Apr 22, 2024 - 14:08 CEST
Update
The engineering team has identified the root cause of the issue and is actively working on implementing a solution.
Posted Apr 22, 2024 - 12:53 CEST
Identified
We have identified an issue that affects a subset of customers and are working towards a resolution.
The initial investigation shows that document creation fails for documents with certain Dynamic elements.
Further updates will be posted here soon.
Posted Apr 22, 2024 - 11:16 CEST
This incident affected: Templafy Hive (Library & Dynamics).