Service degradation - Slowness in WebApp
Incident Report for Templafy
Postmortem

On August 3, 2023, starting 8:40 AM, 5% of the users started to have high response times which lead to slowness in the WebApp and customer cases started to appear. At 10:49 AM CET the engineers started to investigate the issue. The engineers identified the issue immedietly and started mitigating the issue by slowing down some of the large internal requests for background tasks to prevent slowness. At 11:40 AM CET the slowness disappeared and daily work could be processed normally. We monitored the behavior until 2:21 PM CET and could not see any slowness, both from our side and customers reported that the issue is not affecting them anymore. The incident was mitigated.

To prevent this issue in future, we aligned the incoming request amount with our infrastructure scaling rules to be more reactive when large requests are being handled by our background tasks.

Posted Aug 04, 2023 - 14:55 CEST

Resolved
The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Aug 03, 2023 - 14:21 CEST
Monitoring
The incident has been successfully mitigated, and our team is actively monitoring the situation to ensure ongoing stability and performance. We are observing the systems to prevent any further disruptions.
Posted Aug 03, 2023 - 11:40 CEST
Investigating
We are currently investigating this issue.
Posted Aug 03, 2023 - 10:57 CEST
This incident affected: Templafy One (WebApp).