Service degradation - Content Library is not accessible in West Europe (Production 0)

Incident Report for Templafy

Postmortem

Investigation
The issue began at 11:05 AM CET on January 29, 2026, following a deployment to West Europe (Production 0). From that point, some users were unable to access the content library in both the Web Add-in and VSTO Add-in. The engineering team initiated an immediate investigation and quickly traced the issue to recent changes made to enhance the end-user experience. We found that the update caused an issue during application startup, which prevented the feature from loading correctly.

Mitigation
Upon identifying the likely cause, the team prioritized restoring access to the content library for affected users. After confirming the issue stemmed from the new changes, the team prepared a rollback of the deployment to remove the problematic update.

Resolution
To resolve the issue, the team rolled back the earlier deployment in West Europe (Production 0) at 12:49 PM CET on January 29, 2026. Once the rollback was completed, access to the content library in both the web add-in and VSTO returned to normal for all affected users.

Post-Incident Actions
To prevent similar issues in the future, we are introducing a new end-to-end test to simulate delayed environment initialization, making it easier to detect these types of timing-related problems before updates go live.

Impact and Scope
This incident affected a subset of users in West Europe (Production 0) who were unable to access the content library in the web add-in and VSTO between 11:05 AM CET and 12:49 PM CET on January 29, 2026. Other clusters and features were not impacted.

We sincerely apologize for the disruption this incident caused. Ensuring a stable and reliable experience is always our top priority. We remain committed to continuous improvement and appreciate your understanding.

Posted Feb 02, 2026 - 12:56 CET

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Jan 29, 2026 - 12:56 CET

Identified

We have identified an issue that affects a subset of customers and are working towards a resolution.
Further updates will be posted here soon.
Posted Jan 29, 2026 - 12:14 CET
This incident affected: Templafy Hive (Library & Dynamics).