Document Agents and Ai Assistant Service Degradation

Incident Report for Templafy

Postmortem

Investigation
The issue was detected at 10:22 AM CET on January 27, 2026, when Document Agents and AI Assistant services began experiencing degraded performance across the West Europe production environments (Production 0, Production 1, and Production 5). The engineering team began an immediate investigation after observing a pattern of failed requests and error responses affecting the document agent functionality.
The root cause was a service interruption in the OpenAI services running on our cloud provider, Microsoft Azure.
Mitigation
The team worked to contain the impact by closely monitoring service health and coordinating with Microsoft.
Resolution
By 6:37 PM CET on January 27, 2026, Microsoft had restored stability in the affected region. As the platform stabilized, document agents in West Europe (Production 0), West Europe (Production 1), and West Europe (Production 5) returned to normal operation and full functionality was restored.
Impact and Scope
This incident affected Document Agent and AI Assistant functionality for tenants in West Europe (Production 0), West Europe (Production 1), and West Europe (Production 5) between 10:22 PM CET and 6:37 PM CET on January 27, 2026. Users experienced intermittent availability issues during this period. The issue was isolated to these clusters and did not impact other regions.

Posted Jan 31, 2026 - 14:19 CET

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Jan 27, 2026 - 20:44 CET

Monitoring

The incident has been successfully mitigated, and our team is actively monitoring the situation to ensure ongoing stability and performance.
Posted Jan 27, 2026 - 18:34 CET

Update

Microsoft has reported the issue on their status page:
https://azure.status.microsoft/en-gb/status
Posted Jan 27, 2026 - 11:57 CET

Identified

We have identified an issue that affects a subset of customers and are working towards a resolution.
We are impacted by an Open AI service availability in Azure, due to this some request using Document Agents and Ai Assistant could experience degraded performance.
Further updates will be posted here soon.
Posted Jan 27, 2026 - 11:44 CET
This incident affected: Templafy Hive (AI Assistant).