Service degradation: In case Productivity Add-in is active, tables inside powerpoint are unusable
Incident Report for Templafy
Postmortem

On May 22, 2024, at 4:58 PM CET, an incident impacting all customers using the Productivity Add-in within the Insider track using the Hive environment was triggered by a code change introducing a bug in PowerPoint, causing errors and numerous popup messages when users attempted to work with tables. Upon detection, the engineering team swiftly initiated an investigation and identified the issue by 5:03 PM CET on May 22. To mitigate the impact, the team promptly executed a plan to downgrade affected users to a previously stable version, completing the action by 5:26 PM CET on May 22. We apologize for the disruption and remain committed to ensuring the reliability and stability of our services.

Posted May 24, 2024 - 12:04 CEST

Resolved
The faulty Productivity Add-in version has been unlisted, affected users can update to the to the previous working version by checking for update inside Templafy Desktop or by restarting their pc. Only customers on the insider version were affected by this issue.

Further information will be provided in a postmortem shortly.
We apologize for the impact to affected customers.
Posted May 22, 2024 - 17:29 CEST
Identified
We have identified an issue that affects a subset of customers and are working towards a resolution.
Further updates will be posted here soon.
Posted May 22, 2024 - 17:08 CEST