Service degradation - Stuf DCR Connector issues
Incident Report for Templafy
Postmortem

On May 6th, at 9:41 CEST, a subset of Templafy customers began experiencing difficulties with Stuf DCR, our service. We sincerely apologize for any inconvenience caused by this issue.

The problem originated from the loss of STUF DCR certificate configuration, which occurred due to an unintended out-of-order execution of data and schema migrations. This unexpected sequence of events resulted in the configuration being overwritten or disrupted, leading to service disruptions and errors for our affected customers.

As soon as we became aware of the issue at 9:41 CEST, our team promptly initiated an investigation to identify the root cause and find a resolution. By 03:43 CEST, we were able to successfully restore the lost data and rectify the underlying problem.

During the restoration process, we closely monitored the situation to ensure that requests were being processed correctly. We are pleased to inform you that normal operations have resumed, and we are now observing successful requests being handled without any issues.

We deeply regret any inconvenience or disruption this incident may have caused for our valued customers. We understand the importance of reliable and uninterrupted service, and we are committed to implementing measures to prevent similar occurrences in the future.

Thank you for your patience and understanding throughout this situation.

Posted Jun 09, 2023 - 13:59 CEST

Resolved
The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Jun 05, 2023 - 15:42 CEST
Monitoring
The incident has been successfully mitigated, and our team is actively monitoring the situation to ensure ongoing stability and performance. We are observing the systems to prevent any further disruptions.
Posted Jun 05, 2023 - 15:09 CEST
Update
Engineers have implemented the fix and currently are working on validating it.

Further updates will be posted here soon.
Posted Jun 05, 2023 - 14:28 CEST
Identified
We have identified an issue that affects a subset of customers and are working towards a resolution.
Further updates will be posted here soon.
Posted Jun 05, 2023 - 12:13 CEST
Investigating
We are currently investigating the issue.
Posted Jun 05, 2023 - 11:42 CEST
This incident affected: Templafy Hive (Integrations).