Service degradation - Potential Issues Updating Word Documents in VSTO Add-ins

Incident Report for Templafy

Postmortem

Investigation
The incident began at 11:19 AM CET on August 12, 2026, following the promotion of Office VSTO add-ins version 7.3.220 to the stable release channel. The issue was detected at 10:25 PM CET on August 13, 2026, after customers reported that Microsoft Word could close unexpectedly when using the Update Document with templates containing images.
The engineering team investigated the reported behavior and identified that a change introduced in version 7.3.220 affected the processing of newly inserted images within document headers during an update. Under certain document and Word view conditions, header content could not be processed reliably, causing the document update to fail or, in some cases, Word to close unexpectedly.

Mitigation
Following the investigation, the engineering team removed version 7.3.220 from the stable release channel to prevent further users from receiving the affected version.
The team restored version 7.3.217 as the stable release, providing users with the previously validated version while the behavior introduced in 7.3.220 was addressed.

Resolution
The incident was resolved at 5:08 PM CET on August 14, 2026, by reverting the stable release to version 7.3.217. This removed the affected behavior from the stable release channel and restored the Update Document functionality to its expected operation.
The engineering team verified the mitigation and confirmed that the product was functioning as expected following the rollback.

Post-Incident Actions
We are strengthening our release validation to reduce the likelihood of similar issues reaching the stable release channel. These improvements include additional manual validation when introducing new plugin versions and more robust dependency validation when updated plugin components are consumed by other Office components.
We are also expanding automated coverage, with a particular focus on integration testing for document update scenarios and interactions with Microsoft Office applications.
Impact and Scope

The incident affected multiple tenants using version 7.3.220 of the Office VSTO add-ins. Users could encounter failures or unexpected Word application closures when using the Update Document functionality, temporarily obstructing affected document workflows.
We sincerely apologize for the disruption caused by this incident. Maintaining a reliable and stable experience is a high priority for us, and we are strengthening our testing and release validation processes to help prevent similar issues in the future. We remain committed to delivering a dependable service to our customers.

Posted Aug 19, 2026 - 14:00 CEST

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Aug 14, 2026 - 16:57 CEST

Identified

We have identified an issue that affects a subset of customers and are working towards a resolution.
Users could encounter issues when updating Word documents using VSTO add-ins.
Further updates will be posted here soon.
Posted Aug 14, 2026 - 16:31 CEST
This incident affected: Templafy Hive (Library & Dynamics).