Update presentation is not working for any PowerPoint presentation

Incident Report for Templafy

Postmortem

Investigation

The incident began on March 5, 2026, at 8:04 AM CET and affected the Document Updater functionality for PowerPoint presentations, where users encountered an error when attempting to update presentations. As a result, PowerPoint presentations could not be updated through the Document Updater.

The issue was detected on March 9, 2026, at 9:32 AM CET, after reports indicated that users were receiving error notifications when attempting to update PowerPoint documents. The engineering team immediately initiated an investigation to determine the cause of the issue.

During the investigation, the team identified that a recently introduced change related to the Templafy Validator functionality for unlocking slides had unintentionally introduced a regression affecting the Document Updater. The change modified the contract used by the VSTO component responsible for processing template configuration. Due to this contract change, VSTO was unable to correctly process the configuration, resulting in errors when users attempted to update PowerPoint presentations.

Mitigation

After identifying the cause of the issue on March 9, 2026, at 9:41 AM CET, the engineering team began implementing a fix to restore compatibility with the existing VSTO integration.

A corrective code change was prepared. The fix ensured that the contract used by the VSTO component could once again correctly process template configuration required by the Document Updater.

Resolution

By 12:05 PM CET on March 9, 2026, the fix had been successfully deployed across all production clusters. Once deployed, the Document Updater functionality for PowerPoint presentations was restored, and users were able to update presentations normally without encountering errors.

Impact and Scope

This incident affected the PowerPoint Document Updater functionality, preventing users from updating PowerPoint presentations through the platform.

The issue impacted tenants across all production clusters, affecting all tenants using the PowerPoint update functionality during the incident window from March 5, 2026, at 8:04 AM CET until March 9, 2026, at 12:05 PM CET.

Post-Incident Actions

The engineering team has reviewed the incident and identified opportunities to improve safeguards around compatibility between platform components.

As part of the follow-up actions:
• Additional review procedures will be introduced for changes that affect contracts used by client integrations such as VSTO.
• The team will investigate approaches for introducing tests that validate backwards compatibility for contract changes, particularly for integrations that rely on existing client-side implementations.
• Internal development guidelines will be reinforced to ensure that contract changes are carefully evaluated for potential downstream impact.

These improvements aim to reduce the risk of similar regressions in the future.

Posted Mar 11, 2026 - 09:34 CET

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Mar 09, 2026 - 12:12 CET

Identified

We have identified an issue that affects a subset of customers and are working towards a resolution.
Further updates will be posted here soon.
Posted Mar 09, 2026 - 10:43 CET

Investigating

We are currently investigating this issue.
Posted Mar 09, 2026 - 09:54 CET
This incident affected: Templafy Hive (Library & Dynamics).