Service degradation: Previews of images from integrations are not loading in add-ins

Incident Report for Templafy

Postmortem

Investigation
The issue began on Friday October 24, 2025, at 9:49 AM CET and was detected later that day at 3:57 PM CET, when users reported that image previews from integration libraries were not loading within add-ins in the Hive environment.
Through analysis of recent changes and deployment logs, the team determined that a recent update related to slide collection previews had unintentionally disrupted the image preview functionality for content connectors. Specifically, the change introduced a missing mapping for previews to a newly required type, causing the affected previews to fail to render.

Mitigation
On Monday October 27, 2025, at 12:35 PM CET, the engineering team began implementing a code fix to restore the correct mapping for content connector previews. At 12:56 PM CET, the fix was packaged and prepared for release.
The fix was first deployed to the West Europe (Production 0) cluster at 1:04 PM CET, where it was confirmed to restore the missing preview functionality. Following successful verification, the fix was rolled out to all remaining production clusters.

Resolution
By October 27, 2025, at approximately 1:15 PM CET, the fix had been successfully deployed across all production clusters. The functionality of image previews from integration libraries in the Hive environment was fully restored. Monitoring confirmed stability and normal operation across all clusters.

Post-Incident Actions
To prevent similar issues in the future, the engineering team has initiated the following improvements:

  • Introduce end-to-end tests that specifically cover preview display functionality for all asset types, including content connector previews.
  • Improve code resilience and type handling to better tolerate future changes in preview logic and asset handling.

These measures will enhance reliability and reduce the risk of regressions during future updates.

Impact and Scope
The incident affected the display of image previews from integration libraries within add-ins in the Hive environment. The impact was limited to a subset of users across multiple production clusters.
We sincerely apologize for the disruption this incident caused. Ensuring a stable and reliable experience is our top priority, and we are continuously improving our processes and test coverage to prevent similar issues in the future.

Posted Oct 28, 2025 - 11:09 CET

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Oct 27, 2025 - 13:10 CET

Identified

We have identified an issue that affects a subset of customers and are working towards a resolution.
The issue is that images from integrations are not showing previews, inserting the image is still working.

Further updates will be posted here soon.
Posted Oct 27, 2025 - 12:27 CET
This incident affected: Templafy Hive (Library & Dynamics).