Service degradation - Users might encounter issues generating powerpoint presentations

Incident Report for Templafy

Postmortem

Investigation
The issue began on September 22, 2025, at 12:32 PM CET, when certain PowerPoint templates containing Templafy fields in layout parts failed during slide insertion. The incident was detected on September 24, 2025, at 5:56 PM CET, after engineering noticing an increase in exceptions related to creating presentations in the Hive environment.
The engineering team immediately initiated an investigation. Analysis showed that recent code changes intended to simplify slide insertion logic had introduced an error affecting specific template configurations. The error occurred only when inserting slides containing Templafy fields within layout parts, leading to an exception during processing.
Mitigation
Once the root cause was understood, the engineering team worked on a fix to remove reliance on a caching mechanism that was triggering the exception. The fix was merged and first deployed to non-production environments for validation.
At 7:23 PM CET on September 24, 2025, the fix was deployed to West Europe (Production 0) and verified shortly thereafter. By 7:40 PM CET, deployment was rolled out across additional production clusters.
Resolution
The resolution was achieved by introducing corrected logic for slide insertion that prevented the exception from being raised. The updated code restored normal functionality across affected environments. By September 24, 2025, at 7:40 PM CET, the deployment was complete in all production clusters.
Post-Incident Actions
The engineering team has taken the following steps to reduce the risk of similar issues in the future:

  • Evaluation of options to broaden automated test coverage to include a wider range of template configurations.
  • Consideration of maintaining code path divergence behind feature flags for longer periods to allow for additional testing before general release.
  • Continued focus on improving detection and logging to catch exceptions more quickly in production.

Impact and Scope
The incident affected a limited number of users working with specific PowerPoint templates that included Templafy fields in layout parts.

  • The issue first appeared in West Europe (Production 0) on September 22, 2025, at 12:32 PM CET, though no affected customers were identified in this cluster.
  • On September 23, 2025, the change was deployed to additional clusters, where users began experiencing failures.
  • The incident was resolved on September 24, 2025, by 7:40 PM CET, once the fix had been rolled out across all clusters.
Posted Sep 29, 2025 - 10:43 CEST

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Sep 24, 2025 - 19:44 CEST

Identified

We have identified an issue that affects a subset of customers and are working towards a resolution.
Further updates will be posted here soon.
Posted Sep 24, 2025 - 18:06 CEST
This incident affected: Templafy Hive (Library & Dynamics).