Service degradation - Failure to request Public API (Production 0)

Incident Report for Templafy

Postmortem

Investigation
The issue began on February 20, 2026, at 11:42 AM CET in the Hive environment on West Europe (Production 0), where public API requests started failing due to an authentication problem. The incident was detected by the engineering team at 1:09 PM CET, and the team promptly began investigating. The cause was quickly identified as being related to recent changes in how user logins are handled.

Mitigation
To restore service as quickly as possible, the engineering team rolled back the recent changes to the authentication system. This rollback was implemented promptly after the root cause was identified, and system functionality was closely monitored to ensure public API access was restored.

Resolution
Normal API functionality was restored shortly after the rollback. The incident was considered resolved once user authentication to the public API was verified as successful across the environment.

Post-Incident Actions
After resolution, the engineering team began a thorough review of the deployment process and the changes that contributed to the incident. The following actions are being taken:

  • Automated checks will be put in place to confirm that critical features, such as public API access, work as expected after any changes.
  • Our monitoring will be improved so that potential issues with user authentication are detected even sooner.

Impact and Scope
The incident was limited to tenants in the West Europe (Production 0) environment. During the incident window, affected users were unable to log in or make successful requests through the public API. Other environments and clusters were not impacted.

We sincerely apologize for the disruption caused by this incident. Maintaining a reliable and seamless experience remains our highest priority, and we are taking immediate steps to further improve our service reliability.

Posted Feb 23, 2026 - 17:22 CET

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Feb 20, 2026 - 15:29 CET

Identified

We have identified an issue that affects a subset of customers and are working towards a resolution.
Further updates will be posted here soon.
Posted Feb 20, 2026 - 15:22 CET

Investigating

We are currently investigating this issue.
Posted Feb 20, 2026 - 14:36 CET
This incident affected: Templafy Hive (Authentication).