Assets are not visible in new experience West Europe (Production 0)

Incident Report for Templafy

Postmortem

Investigation

The incident began on March 4, 2026, at 8:04 AM CET, when Templafy assets were not visible in the new end-user experience within the Hive environment. The issue affected users attempting to access templates through the updated experience.

The issue was detected at 9:07 AM CET after reports indicated that templates were missing from the library interface in the new experience. The engineering team immediately initiated an investigation to determine the cause of the behavior.

During the investigation, the team reviewed recent changes related to Library and the handling of space-aware data. The analysis identified that recent hardening improvements intended to strengthen security around space-aware data had unintentionally introduced filtering conditions that prevented assets from appearing in the new end-user experience, even when users had the correct permissions.

Mitigation

At approximately 9:27 AM CET on March 4, 2026, the engineering team began implementing mitigation steps after identifying the likely source of the issue.

The team determined that reverting the recent changes related to the filtering logic would restore the expected behavior. Work to revert the changes was initiated shortly after confirmation of the root cause, and updates were communicated internally throughout the mitigation process.

Resolution

At 10:15 AM CET on March 4, 2026, the rollback of the filtering changes was completed on West Europe (Production 0).

Following the rollback, the library filtering behavior returned to normal, and Templafy assets became visible again in the new end-user experience for affected users. Verification confirmed that users with the appropriate permissions could once again access templates as expected.

Impact and Scope

The incident affected tenants hosted on West Europe (Production 0) where the new end-user experience feature flag or document agents with library functionality enabled were in use.

During the incident window, affected users were unable to see Templafy assets within the new end-user experience in Hive. The issue did not impact the underlying assets themselves, and access was restored once the filtering logic was reverted.

Post-Incident Actions

The engineering team has identified several follow-up actions to further strengthen reliability and prevent similar issues in the future:
• Establish a clearly maintained list of feature flags that are in public preview or that should be treated as production-impacting if affected by regressions.
• Improve internal testing capabilities to support manual testing scenarios with the new end-user experience, including multiple feature flag configurations.
• Introduce smoke tests for the Library Explorer in the new end-user experience to ensure asset visibility and filtering behavior remain consistent across releases.

These improvements will help ensure that feature interactions and configuration scenarios are validated more thoroughly prior to deployment.

Posted Mar 06, 2026 - 09:36 CET

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Mar 04, 2026 - 10:13 CET

Identified

We have identified an issue that affects a subset of customers and are working towards a resolution.
Further updates will be posted here soon.
Posted Mar 04, 2026 - 09:51 CET

Investigating

We are currently investigating this issue.
Posted Mar 04, 2026 - 09:35 CET
This incident affected: Templafy Hive (Library & Dynamics).