Service degradation - Unable to create documents

Incident Report for Templafy

Postmortem

Investigation

The incident began on March 10, 2026, at 8:04 AM CET and affected document generation and download functionality for some users. In certain cases, documents could fail to generate when templates contained non-ASCII characters in the file name. Additionally, some downloaded documents appeared corrupted.

The issue was detected on March 10, 2026, at 1:58 PM CET, after alerts indicated unusual behavior related to document processing. The engineering team immediately began investigating the issue.

During the investigation, the team found that a recent change related to how documents were stored in blob storage within the Dynamics integration had introduced unexpected behavior. This change caused templates with certain characters in their names to fail during document creation and also led to incorrect references to stored documents, which resulted in corrupted downloads.

Mitigation

The engineering team reverted the recent blob storage changes introduced in the Dynamics integration and removed metadata related to template names that contributed to the failures. The team also corrected the document identification and storage logic to ensure documents were saved and retrieved correctly.

These steps restored normal behavior for document generation and downloads.

Resolution

The fix was deployed on March 10, 2026, and was successfully rolled out to West Europe (Production 0) by 3:56 PM CET.

Following the deployment, document creation and downloads returned to normal operation.

Impact and Scope

This incident affected document creation and document download functionality for customers hosted on West Europe (Production 0).

During the incident window from March 10, 2026, at 8:04 AM CET until March 10, 2026, at 3:56 PM CET, users could experience issues generating documents from templates with certain characters in their names or receive corrupted files when downloading documents.

Post-Incident Actions

The engineering team reviewed the incident and identified opportunities to further improve validation around document storage.

As part of the follow-up actions:

  • Automated tests will be expanded to validate storage paths before documents are stored.
  • Additional validation will ensure that document identifiers and storage locations remain consistent during processing.
  • The team will continue improving how template name metadata is handled to support a wider range of naming conventions.
Posted Mar 13, 2026 - 09:29 CET

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Mar 10, 2026 - 15:47 CET

Identified

We have identified an issue that affects a subset of customers and are working towards a resolution.
Further updates will be posted here soon.
Posted Mar 10, 2026 - 14:28 CET
This incident affected: Templafy Hive (Library & Dynamics).