Service Degradation: Dynamic Slide Insertion Issues in PowerPoint in West Europe (Production 0)

Incident Report for Templafy

Postmortem

Incident Initiation
At 10:22 AM CET on April 4, 2025, an issue was identified affecting the dynamic slide insertion feature in PowerPoint. Certain dynamic assets could not be inserted into documents, obstructing users in their daily work. The issue was officially detected at 3:00 PM CET. It was determined that the problem impacted a subset of customers within the West Europe (Production 0) environment.

Investigation
On April 7, 2025, at 11:11 AM CET, engineers began investigating the incident. The initial focus was to assess whether other production clusters were impacted. By 12:02 PM CET, engineers confirmed that the issue was limited to the West Europe (Production 0) environment. Investigation identified that allowing users to access the preview page by passing the asset ID in the URL inadvertently caused some dynamic assets to fail to be inserted into documents.

Mitigation and Resolution
As a mitigation effort, engineers reverted the behavior that allowed accessing the preview page by passing the asset ID in the URL. The change was deployed to the QA environment at 12:13 PM CET. Following successful validation, the fix was deployed to the West Europe (Production 0) environment at 12:22 PM CET, restoring dynamic slide insertion functionality.

Impact and Scope
Scope: The incident was limited to a subset of customers on West Europe (Production 0) cluster who were using the dynamic slide insertion feature in PowerPoint.
User Experience: Users were unable to insert dynamic slides into documents, impacting their daily workflows.

Post-Incident Actions
To prevent similar incidents in the future, the engineering team will enhance validation procedures for URL-based asset access features and improve regression testing coverage for dynamic asset insertion functionalities.

Posted Apr 08, 2025 - 11:07 CEST

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Apr 07, 2025 - 20:30 CEST

Monitoring

The engineering team has deployed a fix and confirmed that the issue, which impacted only a subset of customers in West Europe (Production0), has been successfully mitigated. We are actively monitoring the situation to ensure ongoing stability and performance and are closely observing the systems to prevent any further disruptions.
Posted Apr 07, 2025 - 14:26 CEST

Identified

We have identified an issue in the Dynamic slide insertion that affects a subset of customers and are working towards a resolution.
Further updates will be posted here soon.
Posted Apr 07, 2025 - 13:42 CEST
This incident affected: Templafy Hive (Library & Dynamics).