DNS issue on accessing Templafy - All production environments

Incident Report for Templafy

Postmortem

Investigation
On December 12, 2025, at 09:11 AM CET, a subset of users began experiencing issues when accessing Templafy Hive and Templafy One. The incident was detected at 09:19 AM CET by our internal monitoring and alerting systems. Users experienced symptoms such as security certificate warnings, applications not loading as expected, and issues with VSTO Add-ins.
The engineering team immediately began investigating. Further analysis confirmed that a DNS migration introduced an issue that affected how the templafy.com domain was resolved, which temporarily prevented users from reaching Templafy services correctly.

Mitigation
At 09:35 AM CET, the engineering team corrected the configuration change and restored it to a valid and stable state. This action stopped further impact for users accessing the services after that time.
Because internet access settings can be cached locally, recovery times varied between users depending on their network environment. The team actively monitored service availability and access patterns to ensure stabilization.

Resolution
Following the configuration correction, Templafy Hive and Templafy One recovered automatically for most users. By 10:44 AM CET on December 12, 2025, the majority of affected users had regained access.
Some users of VSTO Add-ins required manual steps locally before full functionality was restored. Monitoring continued after recovery to confirm that all services were operating normally and no further issues were observed.

Post-Incident Actions
To reduce the likelihood of similar incidents in the future, we are implementing the following improvements:

  • Additional approval and validation steps will be introduced for changes that can affect how users access Templafy services.
  • Clear ownership and responsibility will be established for managing critical configuration areas to ensure changes are reviewed and verified before being applied.

These actions strengthen our safeguards around operational changes and reduce the risk of unintended impact.

Impact and Scope
The incident affected a subset of users who accessed Templafy services between 09:11 AM CET and 09:35 AM CET on December 12, 2025, primarily users whose network settings required a fresh connection at that time.
Impacted services included Templafy Hive, Templafy One, the Templafy website, status page, Templafy Desktop, and VSTO Add-ins. Users accessing the services outside of this time window were not impacted.

We sincerely apologize for the disruption this incident caused. Providing a stable and reliable service is a top priority for us, and we are committed to continuously improving our processes to prevent similar situations in the future.

Posted Dec 17, 2025 - 16:20 CET

Resolved

The incident has been resolved, and further information will be provided in a postmortem shortly.

We apologize for the impact to affected customers.
Posted Dec 16, 2025 - 11:37 CET

Update

We are continuing to monitor for any further issues.
Posted Dec 15, 2025 - 09:48 CET

Monitoring

The incident has been successfully mitigated, and our team is actively monitoring the situation to ensure ongoing stability and performance. We are observing the systems to prevent any further disruptions.
Posted Dec 12, 2025 - 10:44 CET

Identified

Due to a DNS update, a subset of end users might experience security prompt regarding SSL certificates on accessing Templafy. We have identified the issue and are working towards a resolution.
Further updates will be posted here soon.
Posted Dec 12, 2025 - 09:59 CET
This incident affected: Templafy One (WebApp, Public API) and Templafy Hive (Account Management, Add-in Management, AI Assistant, Authentication, Email Signature, Integrations, Library & Dynamics, Productivity, Resource Management, User Management).